logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Vince  
#1 Posted : Wednesday, 22 August 2012 9:05:48 PM(UTC)
Vince

Rank: Newbie

Groups: Registered
Joined: 22/08/2012(UTC)
Posts: 3

Hi everyone,

I am currently testing Tandemvids for my dropzone and I have to say it's a really powerful tool when it comes to save time on busy days!

I didn't have any problem getting familiar with the software. Nevertheless, I ran into a problem while trying to create a black video (same procedure as described in the Help file).

Everytime I try to create the (DVD) file, I have the "malfunction" pop-up. The windows event log mentions something like "Object reference not set to an instance of an object" (or something like that - translated from French).
Same happens with bluray file.

Anyone with such a problem? What could be wrong?

Thanks in advance.

Vince
Mick Hardy  
#2 Posted : Wednesday, 22 August 2012 11:17:34 PM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
Hi Vince,

I have the same issue logged with a German Windows installation but haven't managed to reproduce the issue. After the German Nationals, we're going to install a debug version of TandemVids on their computer and see if I can log some data to try and shed some light on the issue.

I think it occurs because I've hard-coded the name of the colour "black" into the code and Vegas 11 expects the translated colour. Vegas 9 has been reported to work fine.

I've also seen a similar issue when an asterisk character has mysteriously appeared in the path of the rendered audio filename on the DVD tab.

Do you have the French or English version of Sony Vegas installed? I'll see if I can reproduce the issue in a virtual machine. What version of Windows do you have installed?

Mick
Mick Hardy  
#3 Posted : Wednesday, 22 August 2012 11:37:49 PM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
As a workaround, you could create the black video manually. Create a new project, insert a video track, right click and insert generated media, select Sony Solid Color and then Black. Set the desired length of the solid colour to 10 minutes.

Render the project using the same engines you have selected on the DVD tab and select the same file names.

This is all the function does. You can then use those files as place holders for your DVD Architect templates.

When you insert a solid colour, is the preset listed as Black or Noir?

Mick
Mick Hardy attached the following image(s):
Sony Black.jpg
Black media.jpg
Vince  
#4 Posted : Thursday, 23 August 2012 11:35:40 AM(UTC)
Vince

Rank: Newbie

Groups: Registered
Joined: 22/08/2012(UTC)
Posts: 3

Hi Mick,

Excellent software but also quick support!

Indeed I have the french version of Vegas installed. I'll try with reinstalling the english version. (When inserting the solid colour, I have "Noir")
I work with :
Vegas pro 11 (64-bit) French
DVD architect 5 (32-bit) English
Windows 7 pro (64-bit) French

If solution 1 doesn't work, I'll try your workaround.

Thanks again,

Vince
Mick Hardy  
#5 Posted : Thursday, 23 August 2012 12:01:14 PM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
I've managed to reproduce this issue by installing the French version of Windows 7. The name of the "Sony Solid Color" plugin is localised even when using the English version of Sony Vegas.

I'm currently working on an architecture change, which will allow language localisation but I'm a long way off release. I'll have a think about a workaround.
Mick Hardy attached the following image(s):
Sony Solid Color - English.jpg
Sony Solid Color - French.jpg
Vince  
#6 Posted : Thursday, 23 August 2012 3:52:31 PM(UTC)
Vince

Rank: Newbie

Groups: Registered
Joined: 22/08/2012(UTC)
Posts: 3

Yep! I tried to create the black video with an english installation of Vegas and I came to the same as conclusion as you did. (I'll try to switch my windows laptop to english and see if it solves the problem).

I also tried the workaround (creating directly the black video in Vegas) but it seems that even if I define a 15min length i always get a 5 sec media... any advice?

Vince

EDIT: solved my problem with your workaround thanks to the guidelines here:
http://www.designstudios...erated-media-t42671.html

EDIT - BIS: finally got it to work!! Had some problems with DVD Architect when burning (I had to untick the "XP theme" option and tick the "skip drive database" one to have it working properly).
In the end, I have a nice video created automatically. Now I just have to fine-tune the vegas file for transitions, texts, etc...
Thank you for your support Mick.

Vince

Edited by user Thursday, 23 August 2012 10:55:03 PM(UTC)  | Reason: Not specified

Mick Hardy  
#7 Posted : Friday, 24 August 2012 12:01:30 AM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
Thanks for the feedback Vince and glad you got it mostly sorted.

I have a couple of tandems today and then a busy weekend but I'll slip some of the changes from the new version into the current version. This will allow me to localise specific strings so I can support the different language versions of Vegas. I'll start with "Sony Solid Color" and "Black" and at least fix this bug. It shouldn't take too long but I need to download the different language versions of Windows and then test across the different versions of Vegas. The number of possible combinations is huge.

I'll also have to address the key strokes sent to DVD Architect as they change across the localised versions as well. The default renderers are also different.

Mick
Mick Hardy  
#8 Posted : Tuesday, 28 August 2012 12:10:11 AM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
This is a quick update if anyone is following the discussion as I've had time to do some more research on the issue.

It only affects Vegas 11 and only when installed on different language versions of Windows. Vegas 8 is English only. Vegas 9 and 10 use the English name for the "Sony Solid Color" plugin, even if another language is selected during installation. Vegas 11 uses the foreign language name for the plugin, even if the English version is installed. The names of the colors do change as expected with the language selected during the installation of Vegas.

I did have a fix in place and was testing the changes when I discovered how complicated it all is, so I'm back to the drawing board trying to sort it out.

I haven't seen these options in DVD Architect so I'm not sure why they affect the burn process but I'll investigate further as soon as I've fixed the foreign language issues.
Quote:
I had to untick the "XP theme" option and tick the "skip drive database" one to have it working properly


There is also an error during installation of TandemVids on a foreign language version of Windows, which is generated when attempting to set the permissions of the Swoopware data folder. I've fixed this issue for the next release but a workaround is to set the permissions manually to full control for all users. The location of the hidden folder on English machines is "C:\Program Data\Swoopware" but the name of the program data folder changes according to the base language of Windows.

Mick
Mick Hardy  
#9 Posted : Friday, 31 August 2012 6:33:02 AM(UTC)
Mick Hardy

Rank: Advanced Member

Groups: Administrators, Registered
Joined: 14/07/2010(UTC)
Posts: 411
Man
Location: Townsville

Was thanked: 20 time(s) in 18 post(s)
I've released a new version available from here to address this issue.

TandemVids will work out of the box with French and German installations of both Sony Vegas and DVD Architect. Other languages will work as well but require a bit of tweaking.

If you currently have the English editions installed on French or German versions of Windows, you should remove them and install the local versions.

If you have an odd configuration such as a French version installed on an English edition of Windows, you will need to manually adjust the key strokes sent to DVD Architect and select the correct plugin and colour. These can be changed from the defaults shown under Options.

I hope that helps Vince. I can almost speak French now but I clicked a lot of wrong buttons in the process.
Mick Hardy attached the following image(s):
Options - Couleur unie Sony.jpg
Options - Couleur unie Sony - Noir.jpg
Options - DVD Architect.jpg
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.